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Abstract- Web Accessibility is about making web accessible to users with impairments. More specifically, users with disabilities can 
understand and commune with web. Web page is accessible if it can be used efficaciously by users with and without disability. 
 
The paper focuses on the tests carried to verify the accessibility of a Web Page. 
It discusses the underneath areas: 

• Web Accessibility Testing Introduction 
• Categories of Disabilities 
• Web Accessibility Standards and Guidelines  
• Web Accessibility Testing Techniques 
• Web Accessibility Testing Tools 

 Index Terms- Web Accessibility Testing, Web Accessibility Standards and Guidelines, Web Accessibility Testing Techniques, Web 
Accessibility Testing Tools 
 

I. INTRODUCTION 

Accessibility Testing ensures the accessibility of a Website. 

Web Accessibility Testing makes web products usable & accessible to people who have any form of disability. It intends smooth 
access of web to people with disablements. 
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II. CATEGORIES OF DISABILITIES  

Categories of Disabilities: 
• Visual  
• Hearing/ Auditory 
• Mobility 
• Cognitive 

Visual Disability comprises blindness, weak vision, tunnel vision, Dimness, Extreme near- or far-sighted and color blindness. 
 
Auditory Disability comprises deafness, hard of hearing and High/low frequency hearing loss. 
 
Mobility Disability is a physical impairment that considerably limits movement such as lifting, walking, and typing. It comprises of 
Repetitive Stress Injuries (RSI), Arthritis, Stroke, Spinal Cord Injuries, ALS and Loss of limbs or digits. 
 
Cognitive Disability is a category of mental health disorder that affects learning, memory, perception, and problem solving. It 
comprises dyslexia and short-term memory deficit.  
 

III. WEB ACCESSIBILITY STANDARDS AND GUIDELINES 

 
 WCAG 1.0 Web Content Accessibility Guidelines 1.0  

o http://w3.org/TR/WCAG10  
 Section 508 Standards  

o http://www.access-board.gov/508.htm  
 WCAG 2.0  

o http://w3.org/TR/WCAG20/  
 IBM web guidelines 

o http://ibm.com/able/guidelines/web/accessweb.html  
 

IV. WEB ACCESSIBILITY TESTING TECHNIQUE - MANUAL TEST 
 
Manual Tests 
 
Manual test is usually actioned by an accessibility test expert who is technically cognizant of all the accessibility compliances and 
nitty-gritty. This approach helps to attain end-to-end testing of any website. 

In addition, Assistive tools and technologies such as screen readers and magnifiers can help in interacting with the application in a 
realistic setup and real-time challenges.  
 

Following is the list of manual tests which can be executed on different browsers (IE, Firefox, Chrome etc.) to test Accessibility: 

1. Validate HTML 

Validate your code using the W3C HTML Validator.  

• Open the W3C HTML Validator site.  

• Enter the application URL in Address and click the Check button. 

http://en.wikipedia.org/wiki/Mental_health_disorders
http://w3.org/TR/WCAG10
http://www.access-board.gov/508.htm
http://w3.org/TR/WCAG20/
http://ibm.com/able/guidelines/web/accessweb.html
http://www.disabled-world.com/assistivedevices/computer/
http://validator.w3.org/
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2. Headings  

In the W3C HTML Validator under More Options, select the “Show Outline” option and validate that headings are in the right 
order in the Web Application. 

 
 

3. Fonts 

Verify the text size and form field text size by increasing the text. 

Change the browser text size to ‘Largest’ to test the large fonts by performing the below action. 

• Activate large fonts in Internet Explorer, open IE > navigate to the View menu >Text Size >Select “Largest”.  

4. High Contrast 

Verify that changing the color scheme to High Contrast intact the page contents display and page information is not lost. 

Change the high contrast in windows by performing the below action 

• Open the Control Panel> navigate to “Ease of Access Center”> click on “Make the computer easier to see”. Under “High 
Contrast” section, select a High Contrast color scheme. 

• High Contrast can also be turned on or off using keyboard shortcut keys, press left ALT + left SHIFT + PRINT SCREEN> a 
pop up to turn on High Contrast is displayed>click on Yes button to enable High Contrast. 
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5. Alternate Text 

Alternate text is the text associated with an Image. Images should include AltText to make these images accessible especially by 
people with visual disabilities.  

Screen readers can read text associated with images for the people with disable impairment. In Internet Explorer, hover the mouse 
over each image; the Alt text will display the image tool tip. 

6. Captions and Transcripts  

Web audio and video content can be accessible to people who have hearing disabilities by allowing Captions and Transcripts. 
Check that your videos recordings have captions and transcripts with audio. 

7. Skip Navigation 

Web pages having Skip Navigation Links are easily accessible to people with mobility impairments.  

Verify by pressing Ctrl+Home keys to move focuses to the top of the page. Use the Tab key to start moving through links. Make 
sure that “Skip to Content” link is visible near the top. 

8. Tab Order & Link Text 

Using Tab key in right order should access Fields and links. Text linked with each link should be unique and apprehensible. 

9. Form Labels 

Verify that - 

• Form label is accessible, check by putting the mouse on label form field; flashing cursor should appear to the linked field.  

• Form field has a label. If a field label is missing, hover the mouse over the field to verify valid title attribute, which will 
appear as a tool tip. 

10. Keyboard Operations 

Verify that all the dynamic elements (drop-down menus, tab pages, Flash interfaces, etc.) are accessible using keyboard. Check 
using the Tab key, up/down arrows, space bar, etc. to check the accessibility of all the dynamic elements. 

11. PDF Documents 

Open PDF document and click on File> Save as Text>Save the text file. Open the saved text file and check that all text of pdf file 
is present in text file in the correct order. 

12. PDF Forms 

Check that each form field is accessible through keyboard and contains label, verify that putting the mouse over each form field 
displays label as a tool tip. 

13. Disable styles and linearize tables 

Verify that contents without style are displayed in order and apprehensible. Check the styles using WAVE or with the “Web 
Developer toolbar” extension for Firefox. 

14. Test content scaling 

Check the test content scaling by increasing the font size in web browser to 200% and verify that page is readable and usable. In 
order to enlarge the images, zoom the web page and check text in image is readable. 
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15. Testing with Assistive Technology 

 Screen Readers 

Screen reader tests elements which cannot be checked in any other reporting tool. These include Flash objects, interactive 
elements and unique plugins and documents. 

Common screen reader tools include 

• JAWS– used by approximately 65% of blind users 
• Voiceover – free on a Mac or iPhone/iPad 
•  NVDA – free for Windows 

 Screen Magnifiers 

Screen magnifiers allow the user to magnify the screen many times its usual size and test the accessibility for disabled. 

 

V. WEB ACCESSIBILITY TESTING TECHNIQUE - AUTOMATED TEST 
 
Automated Tests  
 
Automatic testing validates much faster, and gives a good idea of the accessibility. However, there are certain issues which automated 
testing cannot detect. This depends on the standards or guidelines we are testing for. 
 
Following is the list of automated tests which can be executed on different browsers (IE, Firefox, Chrome etc.) to test Accessibility 
 
1. aDesigner 

This is a tool developed by IBM which simulates the experience of visually impaired individuals so that the designer can better 
understand the needs of disabled people and develop applications accordingly. 

aDesigner can be accessed using URL http://www.eclipse.org/actf/downloads/tools/aDesigner/ 

2. WebAnywhere 

This is a browser based tool that works similarly to the screen readers like Jaws. It assists the readers how to read the web page. 

WebAnywhere can be accessed using URL http://webanywhere.cs.washington.edu/ 

3. Vischeck 

This tool is used to simulate how a web page or an image will be viewed by people affected with color-blindness. This can be 
done by entering URL or uploading images. 

Vischeck can be accessed using URL http://www.vischeck.com/ 

4. Web accessibility toolbar 

WAT is an extension of Internet explorer or Opera that offers web page designers with useful features in the analysis of web page. 
One best feature is Grey Scale feature which helps to find low contrast spots in the design. 

Web accessibility toolbar can be accessed using URL http://www.wat-c.org/tools/ 

http://www.eclipse.org/actf/downloads/tools/aDesigner/
http://www.eclipse.org/actf/downloads/tools/aDesigner/
http://webanywhere.cs.washington.edu/
http://webanywhere.cs.washington.edu/
http://www.vischeck.com/
http://www.vischeck.com/
http://www.wat-c.org/tools/
http://www.wat-c.org/tools/
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VI. WEB ACCESSIBILITY TESTING TOOLS 

 
1. AChecker (Accessibility Checker)  

Accessibility Checker is an open source web accessibility evaluation tool. This tool tests web accessibility by entering web page 
URL or by uploading its HTML file at AChecker. 

AChecker provides option to select an international accessibility guideline for accessibility check: 

• WCAG 1.0 (International) 
• WCAG 2.0 (International) 
• BITV 1.0 (Germany) 
• Section 508 (U.S.) 
• Stanca Act (Italy) 

It also gives the option to choose report format (View by Guideline and View by Line Number). 

AChecker can be accessed using URL “http://achecker.ca/checker/” 

 

 

2. Accessibility Valet  

Accessibility Valet is a web accessibility test tool which tests the application accessibility compliance w.r.t.W3C Web Content 
Accessibility Guidelines (WCAG) or Section 508.  

       Accessibility Valet can be accessed using URL “http://valet.webthing.com/access/url.html” 

 

3.  WAVE  

WAVE is very utile web accessibility tool. WebAIM has provided several options to use WAVE: 

http://achecker.ca/checker/
http://valet.webthing.com/access/url.html
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• URL can be entered on the WAVE webpage. WAVE will show the original web page with icons and indicators which 

reveals the accessibility of the page. URL can be entered in http://wave.webaim.org/ or 

“http://wave.webaim.org/report#/YOUR+URL+HERE”. 

• WAVE provide the option to upload a file can be uploaded or enter HTML code to check. 

• WAVE toolbar is also available to run the WAVE reports in Firefox. WAVE toolbar can be downloaded from 

“http://wave.webaim.org/toolbar/”. 

WCAG 1.0 and Section 508 guidelines are used by WAVE for the webpage evaluation. 

 

4.  Web Accessibility Toolbar for Internet Explorer  

Web Accessibility Toolbar is used to validate accessibility manually. Tool bar has functionality: 

• To identify components of a web page 
• To Provide access to alternate views of page content 
• To Facilitate the use of third party online applications 

Web accessibility toolbar follow the WCAG 1.0, Section 508 and BITV guidelines.  

5. The Color Contrast Analyser  

Color Contrast Analyser checks the color contrast (foreground/background color combinations) and color visibility. It checks the 
color contrast against WCAG 2.0 color contrast criteria. It also provides the feature to simulate some visual conditions such as 
color blindness and cataract. Tool helps to determine that contrast ratio between two colors can be read or not by visually 
challenged people.  

http://wave.webaim.org/
http://wave.webaim.org/report#/
http://wave.webaim.org/toolbar/
http://www.w3.org/TR/WCAG20/
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6. EvalAccess 2.0   

EvalAccess2.0 is developed by the University of the Basque Country in Spain. This tool can evaluate a single web page as well as 
an entire website for WCAG 1.0 and Section508 compliance. 

EvalAccess provides the beneath ways to test web accessibility: 

• Evaluate Single URL- To use this method user needs to enter the URL of every page and evaluate it. 
• Evaluate Website- Using this method entire website can be evaluated. 
• Evaluate HTML source- This method is used to evaluate the HTML source code. Enter the HTML source code and 

evaluate it. 
 

 
 

7. FAE (Functionality Accessibility Evaluator)  

FAE evaluates web page. 
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Evaluation results returns in following categories: Navigation and Orientation, Text Equivalents, Scripting, Styling and HTML 
Standards. 

FAE can be accessed using URL “http://fae20.cita.illinois.edu/” 

 

8. AccessColor  

AccessColor checks the color brightness, color combinations and color contrast between colors. It ensures that color contrast can 
be accessed by people with visual impairments. 

AccessColor also helps in finding appropriate color combinations within HTML and CSS documents in order to test the contrast 
between each color combination. It provides the option to only errors and warnings in report or view full report with details. 

AccessColor checks the color combinations against WCAG 1.0 guidelines. 

AccessColor can be accessed using URL “http://www.accesskeys.org/tools/color-contrast.html”. 

 

9. Hera (Version 2)  

Hera is a web-based system that performs the accessibility test as per the WCAG1.0 guidelines. It does some automation testing 
and guides users through tests which need to be done or confirmed manually.  

Hera can be accessed using URL “http://www.sidar.org/hera/”. 

 

http://fae20.cita.illinois.edu/
http://www.accesskeys.org/tools/color-contrast.html
http://www.sidar.org/hera/
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10. Firefox Accessibility Extension  

Firefox Accessibility Extension is an add-on available for Firefox which makes people with disabilities to view and navigate web 
page contents. To download the Accessibility Extension open Firefox and navigate to Tools>Add-ons>Accessibility Extension. A 
new menu bar “Accessibility” is displayed with number of features: 

• Reports(Accessibility Issues) 
• Navigation (Title, Headings, Links, Forms, Data Tables, Language Changes etc.) 
• Text Equivalents (List of Images, List of Objects, List of Abbreviations etc.) 
• Scripting (Focus Inspector, List of ARIA Widgets, Disable Scripting etc.) 
• Style (Colour Contrast, Text Flow, Text Sizing, High Contrast View etc.) 
• Validators (W3C Specifications, HTML Validator, CSS Validator, Link Checker etc.) 
• Tools (FAE, WebAIM WAVE, Cynthia Says, WebXact, TAW etc.) 
• Keyboard (Keyboard Shortcut Options, Disable Access Keys etc.) 

 

 

11. TAW Online  

TAW (Web Accessibility Test) is  an online tool for the accessibility test  of web sites based on the W3C Web Content 
Accessibility Guidelines. It gives the option to select a guideline WCAG1.0 or WCAG2.0. It also gives the option to select 
Level Analysis (Level A, Level AA and Level AA). As per the selected WCAG guideline standard and level, it tests the web site. 

TAW can be accessed using URL “http://www.tawdis.net/ingles.html” 
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12. PDF Accessibility Checker (PAC) 

PDF Accessibility checker is a freeware windows tool to check the accessibility of PDF files. PAC is recommended by W3C for 
checking the accessibility of PDF files. 

PAC can be used by opening the “PDF Accessibility Checker 2.0.exe”, PAC can be downloaded from “http://www.access-for-
all.ch/en/pdf-lab/pdf-accessibility-checker-pac.html”. 

 

VII. CONCLUSION 

Accessibility testing assists in making application disabled friendly. Accessibility testing may be challenging for testers because they 
are unfamiliar with disabilities. It is better to work with disabled people who have specific needs to understand their challenges.  

In addition, it’s a myth that creating accessible website and testing them is expensive. It is not limited to disabled; it also improves the 
usability of application which helps regular users as well.  

 

http://www.access-for-all.ch/en/pdf-lab/pdf-accessibility-checker-pac.html
http://www.access-for-all.ch/en/pdf-lab/pdf-accessibility-checker-pac.html
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